Es hora de dejar atrás PHP 7.0

Es hora de dejar atras PHP 70

Hace cierto tiempo, PHP 7.0 introdujo esenciales mejoras de desempeño para todas y cada una de las aplicaciones web, incluido WP. Nuestros sacrificios por popularizarlo entre nuestros clientes del servicio han dado como resultado que muchos sitios retornen más veloz que ya antes. Sin embargo, se han lanzado 2 versiones más recientes de PHP desde entonces: setenta y uno y setenta y dos. Ahora es el instante de actualizar a una de estas nuevas versiones.

PHP setenta y uno ahora está predeterminado para nuevas cuentas

La versión predeterminada de PHP en nuestros servidores siempre y en toda circunstancia se escoge teniendo presente la seguridad. Cuando sale una nueva versión, siempre y en toda circunstancia nos apuramos a ponerla a predisposición de nuestros clientes del servicio. Gracias a la configuración de nuestro servidor, que deja múltiples versiones de PHP, cualquiera puede empezar a utilizar la última versión de PHP justo después de su lanzamiento. Sin embargo, asimismo somos cautelosísimos a la hora de lanzar la nueva versión estándar. Siempre procuramos dar a los dueños de sitios y desarrolladores de complementos el tiempo preciso ya antes de efectuar el cambio a fin de que su código sea compatible con la última versión.

Ahora que PHP 7.0 ya no cuenta con el apoyo activo del equipo de PHP, hemos alterado la versión predeterminada de PHP para todos nuestros servidores a PHP setenta y uno. Por lo tanto, todas y cada una de las cuentas nuevas se lanzarán con PHP setenta y uno. Este cambio no se aplica a los sitios existentes y aconsejamos de forma encarecida que todos nuestros usuarios comprueben la versión de PHP que están empleando y actualicen a setenta y uno o bien superior a través de la herramienta PHP Version Manager en cPanel.

Te puede Interesar  20 errores de WordPress y cómo corregirlos en tu sitio web

Nuestros usuarios de WP asimismo pueden contrastar la compatibilidad de su lugar con PHP setenta y uno ya antes de efectuar el cambio en su panel de administración de WP, merced a nuestro complemento SiteGround Optimizer. Se hace de exactamente la misma forma que cuando presentamos esta gran opción para PHP 7.0: sencillamente vaya a la página de configuración de PHP en SiteGround Optimizer y también empiece la verificación de compatibilidad. ¡Tan simple!

¿Qué pasa con PHP setenta y dos?

Por el instante, la última versión libre es PHP setenta y dos y posiblemente se pregunte por qué razón no cambiamos nuestros valores predeterminados con ella. Si bien es un hecho que PHP setenta y dos tiene un mayor desempeño y otras mejoras en comparación con su precursor, asimismo deja fuera muchas funciones. Esto quiere decir que muchos scripts no van a funcionar apropiadamente o bien no van a funcionar en lo más mínimo. En el contexto de WP, si bien el núcleo es plenamente compatible (y realmente aconseja setenta y dos), muchos complementos no van a funcionar apropiadamente ahora. Es de ahí que que ahora hemos decidido aconsejar PHP setenta y uno. Cuando la mayor parte de los desarrolladores de complementos sean compatibles con PHP setenta y dos, actualizaremos de nuevo nuestra versión de servidor predeterminada, verificaremos la compatibilidad del complemento con SiteGround Optimizer y le solicitaremos que actualice a setenta y dos.

Artículos Relacionados

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

Subir

Utilizamos cookies para asegurar que damos la mejor experiencia al usuario en nuestra web. Si sigues utilizando este sitio asumiremos que estás de acuerdo. Más Información